Yo y mi debian

Domingo, 25 de septiembre de 2005

$>Configurar alsa en Debian v- 2.0

Muchos tenemos problemas en debian con el sonido, o, no se oye nada, o solo es capaz de reproducir el sonido de un programa, mientras que los del resto los deja encolados, y cuando lo que esta sonando acaba, suene todo lo que estaba encolada, o que xmms se quede colgado. Helado

Todo esto pasa porque tenemos como servidor de sonido a OSS. Este esta desfasado, y se encuentra en fase de eliminaci?n. Muchas risas

Para instalar alsa en debian, primero tenemos que instalar el alsa.Enfurru?ado

No os preocupeis, aqui estoy para ayudaros.

apt-get install alsa-source alsa-base alsa-oss alsa-utils

Lo mismo no instala algo mas para solucionar dependencias.

Una vez instalado, ejecutamos

alsaconf

Nos saldr? un asistente, el cual nos detectara 1 tarjeta de sonido mas que la que tengamos.

Seleccionamos nuestra tarjeta de sonido, y seguimos avanzando, hasta el final.

En un principio, ya tenemos el alsa configurado. Ahora, probamos si tenemos sonido. Puede que algunos programas como xmms le tengamos que indicar en las preferencias del programa, en sonido, que use el servidor alsa. Si tememos kde, nos tenemos que ir al centro de control, hardware de sonido, y seleccionar el servidor de sonido de alsa.

Si tuvi?ramos mas de 1 tarjeta de sonido, fijase al ejecutar

alsaconf

Nos dice que hay una serie de m?dulos que ha descargado. Tendriamos que copiarlos y pegarlos en

/etc/modules

Hay que hacerlo con las 2, si no, una de las tarjetas no funcionaria.


Suerte
Publicado por Orion220 @ 3:12 | 5 Comentarios | Enviar

Comentarios

$>Añadir comentario
  • Autor: Invitado
  • Fecha: S?bado, 05 de noviembre de 2005
  • Hora: 1:17
me funciono a la perfeccion Gui?o

esta muy buenos los aportes..

Saludos Chankas...

  • Autor: Invitado
  • Fecha: Viernes, 07 de julio de 2006
  • Hora: 18:34
perfecto =) gracias por el aporte

  • Autor: andresito1
  • Fecha: Martes, 10 de abril de 2007
  • Hora: 1:01
Hola. ejecuto el alsaconf:

"not supported PnP or PCI card found"Enfurru?ado. no tiene soporte para la ati?

lspci: Multimedia audio controller: ATI Technologies Inc: Unknown device 4370 (rev 02). alguien le ha pasado?

[email protected]

  • Autor: Invitado
  • Fecha: Lunes, 27 de agosto de 2007
  • Hora: 20:14
Si funcion?, pero cuando reinicio la m?quina, deja de funcionar; y entonces necesito volver a configuar el alsa.

Alguna soluci?n a esto?

Saludos.

  • Autor: Invitado
  • Fecha: Jueves, 18 de febrero de 2010
  • Hora: 12:15
SulGJg <a href="http://yuyndwkpolde.com/">yuyndwkpolde</a>, [url=http://itbakyclyons.com/]itbakyclyons[/url], [link=http://jxdpvuucekor.com/]jxdpvuucekor[/link], http://pmiihpmisylo.com/